Opened 15 years ago

Closed 15 years ago

Last modified 6 years ago

#24 closed defect (fixed)

Compile error on Solaris 8

Reported by: rainer Owned by: rainer
Priority: major Milestone:
Component: main Version: 2.2.1b
Keywords: Cc:

Description

Reported by Jesse:

gcc -DHAVE_CONFIG_H -I. -I./include -O2 -Wall -W -fno-strength-reduce -fno-omit-frame-pointer -DSH_STANDALONE -o sh_extern.o -c x_sh_extern.c
x_sh_extern.c: In function `sh_ext_add_default':
x_sh_extern.c:1080: parse error before `char'
x_sh_extern.c:1089: `p' undeclared (first use in this function)
x_sh_extern.c:1089: (Each undeclared identifier is reported only once
x_sh_extern.c:1089: for each function it appears in.)
x_sh_extern.c:1094: `i' undeclared (first use in this function)
x_sh_extern.c:1096: warning: control reaches end of non-void function

Seems to be caused by the wrong location of the (void) dummy; cast.

Change History (1)

comment:1 Changed 15 years ago by rainer

Resolution: fixed
Status: newclosed

Fixed in changeset [50], released as version 2.2.1c.

Note: See TracTickets for help on using tickets.