Opened 15 years ago

Closed 15 years ago

Last modified 6 years ago

#23 closed defect (fixed)

sstrip does not compile on suse 10.1

Reported by: rainer Owned by: rainer
Priority: major Milestone:
Component: main Version: 2.2.1a
Keywords: Cc:

Description

In file included from /usr/include/asm/elf.h:11,
                 from /usr/include/linux/elf.h:6,
                 from ./src/sstrip.c:22:
/usr/include/asm/system.h:302: error: expected declaration specifiers or ... before u8
/usr/include/asm/system.h:302: error: expected declaration specifiers or ... before u8
/usr/include/asm/system.h:303: error: expected declaration specifiers or ... before u16
/usr/include/asm/system.h:303: error: expected declaration specifiers or ... before u16
/usr/include/asm/system.h:304: error: expected declaration specifiers or ... before u32
/usr/include/asm/system.h:304: error: expected declaration specifiers or ... before u32
/usr/include/asm/system.h: In function cmpxchg_386:
/usr/include/asm/system.h:311: error: too many arguments to function cmpxchg_386_u8
/usr/include/asm/system.h:313: error: too many arguments to function cmpxchg_386_u16
/usr/include/asm/system.h:315: error: too many arguments to function cmpxchg_386_u32
make: *** [sstrip] Fehler 1

The problem is the inclusion of linux/elf.h. Need to include elf.h instead, and determine 32bit/64bit from the executable, as we don't have ELF_CLASS anymore then.

Change History (1)

comment:1 Changed 15 years ago by rainer

Resolution: fixed
Status: newclosed

Fixed in changeset [48] (release 2.2.1b).

Note: See TracTickets for help on using tickets.