Opened 15 years ago

Closed 15 years ago

Last modified 6 years ago

#20 closed defect (fixed)

compiling with oracle support is broken

Reported by: rainer Owned by: rainer
Priority: blocker Milestone: 2.2.1
Component: main Version: 2.2.0
Keywords: Cc:

Description

Compiling with support for Oracle database is broken due to typos in the code (regression). Problems are

sh_database.c:696: error: syntax error before "if"

and

sh_database.c:524: warning: statement with no effect

Furthermore, gcc complains about aliasing:

sh_database.c:623: warning: dereferencing type-punned pointer will break strict-aliasing rules
sh_database.c:658: warning: dereferencing type-punned pointer will break strict-aliasing rules

Change History (1)

comment:1 Changed 15 years ago by rainer

Resolution: fixed
Status: newclosed

Fixed in changeset [45].

Note: See TracTickets for help on using tickets.