Opened 12 years ago

Closed 12 years ago

Last modified 4 years ago

#80 closed defect (fixed)

'make deb' fails with --enable-stealth *OR* --with-config-file

Reported by: rainer Owned by: rainer
Priority: major Milestone: 2.3.7
Component: main Version:
Keywords: Cc:

Description

Reported by marc:

some ./configure strings will cause dh_builddeb to bail out when trying to put together a debian package. In my example below it happens when I add --enable-stealth *OR* --with-config-file

/configure --enable-stealth=128 && make deb
(scroll cut)
dh_builddeb
dh_builddeb: Compatibility levels before 4 are deprecated.
dpkg-deb: conffile `/etc/samhainrc' does not appear in package
dpkg-deb: building package `samhain' in `../samhain_2.3.6-1_i386.deb'.
dh_builddeb: command returned error code 512
make: *** [binary-arch] Error 1
debuild: fatal error at line 1228:
debian/rules binary failed
Error ... cannot find package file
(failure!)

Change History (3)

comment:1 Changed 12 years ago by rainer

The failure with --enable-stealth is due to the imagemagick package not installed (thus stealth config file cannot be created). However, the failure with --with-config-file is a confirmed bug.

comment:2 Changed 12 years ago by rainer

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in changeset [125].

comment:3 Changed 4 years ago by cheap-viagra

XeBcSM Hello! Very good site!

Note: See TracTickets for help on using tickets.