Opened 15 years ago

Closed 15 years ago

Last modified 6 years ago

#57 closed defect (worksforme)

yulectl socket problem

Reported by: markusf Owned by: rainer
Priority: major Milestone: 2.3.3
Component: main Version: 2.3.2
Keywords: Cc:

Description

yule v 2.3.3

I always get this error when I send the RELOAD for a client.

/usr/sbin/yulectl -v -c RELOAD client-xxx

# Waiting for confirmation.
ERROR: Bounced message != original message (possible reason: superfluous password).
ERROR: receiving data from server failed.

it's the same in beltane and on cli (I've tested with correct SetSocketAllowUid?: beltane = wwwrun, cli = root)

the LIST and LISTALL command doesn't bring an error

/usr/sbin/yulectl -c LISTALL
001: xxxxxxx@LISTALL:dummy

I've read the documentation of yulectl and the two methods
when I set the 'SetSocketPassword? = xxxx' in the yulerc, yule writes out a warning

<log sev="WARN" tstamp="2007-03-22T10:20:14+0100" msg="Config option SetSocketPassword not supported, use SetSocketAllowUID" subroutine="sh_socket_password" />

so I only used the SetSocketAllowUid? option in the yulerc and removed the ~/.yulectl_cred passwordfile and yulectl tells me, that the password file is missing:

/usr/sbin/yulectl -v -c LISTALL

# Password file (/root/.yulectl_cred) missing
# Waiting for listing.
001: >>>>  xxxxx@LISTALL                             dummy  2007-03-22T10:37:51+0100

what goes wrong here?!?
the password has no @ or other special-chars and has 11 characters

the permissions of the socket file looks also okay:

srwxrwxrwx 1 root root 0 2007-03-22 10:43 /var/run/yule.sock

thank's for your help

Change History (3)

comment:1 Changed 15 years ago by rainer

I only used the SetSocketAllowUid option in the yulerc and removed the ~/.yulectl_cred passwordfile and yulectl tells me, that the password file is missing

You are using -v for verbose output, so you get verbose information. Apart from this information (which could be worded differently/less irritatingly), does it work if you only use the SetSocketAllowUid option and remove ~/.yulectl_cred, or doesn't it?

comment:2 Changed 15 years ago by markusf

I've removed the .yulectl_cred of root, wwwrun and other user I tested.
after this I restartet the apache and yule
the UID in yulerc is now set to the user of apache (under SLES10 it's wwwrun)

when I click reload -> show pending commands I get the following output

LISTALL command submitted to server
001: xxxx@LISTALL:dummy

I ask me, where can he get the password, when the file was removed and services restartet - does yule cache it anyway?

I found out the problem while testing again and writing this comment[[BR]] I'd the option SetSocketPassword? with a comment in the configfile - so it should not be used:

#
SetSocketAllowUid = 30
#SetSocketPassword = xxxx

## --- E-Mail ---

I've removed the option completely and now it works.
so it seems to have an bug, when the option has an comment it must not be used
it has to ignore the option, but it didn't

now my problems are solved completely

thank's a lot for your help

comment:3 Changed 15 years ago by rainer

Resolution: worksforme
Status: newclosed

Problem description sounds like a configuration problem, closed.

Note: See TracTickets for help on using tickets.