Opened 15 years ago

Closed 15 years ago

Last modified 5 years ago

#55 closed defect (duplicate)

yule - using socket and port doesn't work

Reported by: anonymous Owned by: rainer
Priority: major Milestone: 2.3.3
Component: main Version: 2.3.0
Keywords: Cc:

Description

I run samhain in server-client mode. I donated for Beltane and using Version 2.3.3

I need yule to run with socket activated. but when I activate it in the configuration and restart yule, there is an socket file but the TCP connection isn't open any more and so the clients can't connect. so I can't reload or update the client-servers

i've found that with ticket #47 you have fixed a problem with the socket so I tried to compile samhain V 2.3.2 - but yule wont start any more at all so I compiled V 2.3.0 - this version is running but has still the bug with closed tcp port when socket is opened.

my system of yule server: SLES 10 64bit kernel 2.6.16.27-0.6-smp samhain 2.2.3

configure parameters (xxxx=overwritten values): ./configure --enable-base=xxxx '--prefix=/usr' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--localstatedir=/var' '--enable- network=server' '--with-gpg=/usr/bin/gpg' '--with-libwrap' '--enable-xml-log' '--enable-udp' '--with-database=mysql' '--with-sender=sam hain@xxxx' '--with-recipient=notifications@xxxx' '--mandir=/usr/share/man'

thanks for your help

Change History (6)

comment:1 Changed 15 years ago by rainer

Yule "won't start" is not a bug report.

comment:2 Changed 15 years ago by rainer

This appears to be a duplicate of ticket #47. I've tested the specified configuration with samhain 2.3.2 and it works. The reported startup error for yule (for which no details were given) seems to be an unrelated setup problem. For debugging, stop the server (if any is running), then use

yule -p info --foreground

to review detailed startup error reports.

comment:3 Changed 15 years ago by markusf

sorry - I've forgto to post you the error message at startup.

here the output v 2.3.2 with option info:

yule -p info --foreground

<log sev="ALRT" tstamp="2007-03-20T15:01:58+0100" msg="START" program="Yule" userid="0" path="/etc/yulerc" key_uid="7FBCB22F\ Technik\ (Samhain\ Schluessel)\ &lt;technik@xxxxx&gt;" key_id="9DA51214CC322A96264B063FB8AB87B97FBCB22F" />
samhain[14461]: exit on signal 11

here the output v 2.3.2 with option debug:

yule -p debug --foreground

<log sev="DEBG" tstamp="2007-03-20T15:04:22+0100" p.f="sh_forward.c" p.l="2085" p.s="0" msg="Registered xxxxxx, salt 9F2324E5A085DFC5, verifier E831AC874A627779F6AE06CFD76108D9ECAA40AE07BFD9FE7C22456994EB17FD3BD3ACB5587F58062EA4EEE781CEB61A5A79AF1EF7E6C35035231C447EEDA627BED729DAA6C6B142C7B70FD25CF17613FC90669DDB29D3D38F46CC6F78E0AC12379A627A131A4F22FD78930E42DD2E1D8FACC98BC9E8FF33D2A248E602A3D2C" />
<log sev="DEBG" tstamp="2007-03-20T15:04:22+0100" p.f="sh_forward.c" p.l="2085" p.s="0" msg="Registered xxxxxx, salt 07DE2BED7B5D2F94, verifier C84421CC4466D70D0AFD779BA914B5CFE7E1210C7120FDFDFF4A316D5C4FECE4278E557FD6195BED5DC5E96D57EDC23D4AB6EEB87F07C35B27CD78C5A0CA60DD882C009AC3EFCEC6E271270C3147D967CA37A3706063D143BF67B29BD15EDDA2A825FC8D3F12ED39EFD3F5E578E4E20161A36C7DCD0B49A5BB100C37E84B797D" />

---- snip because the other hosts of yulerc all are listed----

<log sev="DEBG" tstamp="2007-03-20T15:04:22+0100" p.f="sh_gpg.c" p.l="734" p.s="0" msg="[GNUPG:] SIG_ID EnS8SMJuS+PG7+y7+n3E7zoV4IA 2007-03-20 1174380793 " subroutine="gpg_check_file_sign" />
<log sev="DEBG" tstamp="2007-03-20T15:04:22+0100" p.f="sh_gpg.c" p.l="734" p.s="0" msg="[GNUPG:] GOODSIG B8AB87B97FBCB22F Technik (Samhain Schluessel) <technik@maxolution.at> " subroutine="gpg_check_file_sign" />
<log sev="DEBG" tstamp="2007-03-20T15:04:22+0100" p.f="sh_gpg.c" p.l="734" p.s="0" msg="[GNUPG:] VALIDSIG 9DA51214CC322A96264B063FB8AB87B97FBCB22F 2007-03-20 1174380793 0 3 0 1 2 01 9DA51214CC322A96264B063FB8AB87B97FBCB22F " subroutine="gpg_check_file_sign" />
<log sev="DEBG" tstamp="2007-03-20T15:04:22+0100" p.f="sh_gpg.c" p.l="734" p.s="0" msg="[GNUPG:] TRUST_UNDEFINED " subroutine="gpg_check_file_sign" />
<log sev="DEBG" tstamp="2007-03-20T15:04:22+0100" p.f="sh_unix.c" p.l="1446" p.s="22" interface="sigaction" msg="Invalid argument" sig="9" />
<log sev="DEBG" tstamp="2007-03-20T15:04:22+0100" p.f="sh_unix.c" p.l="1446" p.s="22" interface="sigaction" msg="Invalid argument" sig="19" />
<log sev="DEBG" tstamp="2007-03-20T15:04:22+0100" p.f="sh_unix.c" p.l="1446" p.s="22" interface="sigaction" msg="Invalid argument" sig="32" />
<log sev="DEBG" tstamp="2007-03-20T15:04:22+0100" p.f="sh_unix.c" p.l="1446" p.s="22" interface="sigaction" msg="Invalid argument" sig="33" />
<log sev="DEBG" tstamp="2007-03-20T15:04:22+0100" p.f="sh_unix.c" p.l="1446" p.s="22" interface="sigaction" msg="Invalid argument" sig="65" />
<log sev="ALRT" tstamp="2007-03-20T15:04:22+0100" p.f="sh_gpg.c" p.l="1034" p.s="0" msg="START" program="Yule" userid="0" path="/etc/yulerc" key_uid="7FBCB22F\ Technik\ (Samhain\ Schluessel)\ &lt;technik@xxxxx&gt;" key_id="9DA51214CC322A96264B063FB8AB87B97FBCB22F" />
samhain[16104]: exit on signal 11

here the output of the running v 2.3.0 with option info:

yule -p info --foreground
<log sev="ALRT" tstamp="2007-03-20T14:58:50+0100" msg="START" program="Yule" userid="140733193388032" path="/etc/yulerc" key_uid="7FBCB22F\ Technik\ (Samhain\ Schluessel)\ &lt;technik@xxxxx&gt;" key_id="9DA51214CC322A96264B063FB8AB87B97FBCB22F" />
<log sev="MARK" tstamp="2007-03-20T14:58:50+0100" msg="Server up, simultaneous connections: 1017" socket_id="3" />
<log sev="INFO" tstamp="2007-03-20T14:59:11+0100" msg="New connection" socket_id="5" />
<log sev="INFO" tstamp="2007-03-20T14:59:11+0100" msg="Force authentication" host="xxxxxx" />

and here is my configuration of /etc/yulerc:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
NotDashEscaped: You need GnuPG to verify this message
[Log]
MailSeverity=crit
LogSeverity=debug
DatabaseSeverity = err
[Database]
SetDBName = xxxxx
SetDBTable = log
SetDBUser = xxxxx
SetDBPassword = xxxxx
SetDBHost = localhost
SetDBServerTstamp = True
UsePersistent = True
[Misc]
Daemon=yes
SetLoopTime = 600
UseClientSeverity = yes
UseClientClass    = yes
SetClientFromAccept = True
SetServerPort=49777
SetUDPActive = True
SetUseSocket = False
SetSocketAllowUid = 30
[Clients]
Client=....
....

thank's for your help

comment:4 Changed 15 years ago by rainer

The issue this ticket originally refers to is a duplicate of ticket #47. The startup error for yule is a different issue (bug in libmysql), thus I've opened ticket #56 for this.

comment:5 Changed 15 years ago by markusf

I've done like you wrote in ticket #56 now oscket and port are open - this works

thank you

comment:6 Changed 15 years ago by rainer

Resolution: duplicate
Status: newclosed

Closed as duplicate of ticket #47.

Note: See TracTickets for help on using tickets.