Opened 9 years ago

Closed 9 years ago

Last modified 6 years ago

#338 closed defect (fixed)

Memory usage grows

Reported by: rainer Owned by: rainer
Priority: major Milestone: 3.0.12
Component: main Version:
Keywords: Cc:

Description (last modified by rainer)

It has been reported (by Maxime V) that memory usage may grow slowly but steadily:

In the company, we've been deploying samhin in a client-server 
configuration for a client over 6 hosts, and problem is, samhain
 daemons eventually gets killed by kernel for eating up too much 
memory.
After a bit of forensics with atop, i saw that samhain clients 
takes between 1.4 to 1.8MB of extra memory every 10 minutes. After 
3 days of uptime, samhain clients reach 500MB which seems a lot to 
me for a HIDS.

Change History (2)

comment:1 Changed 9 years ago by rainer

Description: modified (diff)

comment:2 Changed 9 years ago by rainer

Resolution: fixed
Status: newclosed

Heap profiling with massif indicates that the problem is not a real memory leak but an incorrect use of sh_inotify_ad_watch_later(). Believed to be fixed by changeset [433].

Note: See TracTickets for help on using tickets.